Ask a question?
  • Contact Us
  • Support Case System
  • Support Forum

Can I mix and match client and server components from different OpenLink versions?

OpenLink Software does not support mixed-version installations. Mismatched client and server software may not hinder a user's ability to connect and query. However, version incompatibility issues will arise over time. In fact, users who mix OpenLink 3.x and OpenLink 4.x software can expect specific problems with stability, transactions, and threading. These problems may only be resolved by upgrading the older component.

Be advised - Some users must operate with mixed component installations. This may eventuate when partner customers only upgrade user servers. As stated previously, 3.x and 4.x components tend to generate problems. However, 4.x client components appear to work well with 5.x server components.